git

From AIXTOOLS
(Difference between revisions)
Jump to: navigation, search
m (fix the release date to the date of the download tarball)
 
Line 7: Line 7:
  
 
== Note ==
 
== Note ==
 +
--[[User:Michael Felt|Michael Felt]] ([[User talk:Michael Felt|talk]]) 13:58, 14 April 2021 (CEST) Going to update this soon.
 +
 
--[[User:Michael Felt|Michael Felt]] ([[User talk:Michael Felt|talk]]) 09:32, 19 December 2019 (CET) Git was/is a complex package to build - and SO many dependencies. HOWEVER, the good news - no dependencies in this package - EXCEPT for the OpenSSL requirements. NB: git-2.24.1 is a security release fixing something - link comes later - that has been there forever. Now gone!
 
--[[User:Michael Felt|Michael Felt]] ([[User talk:Michael Felt|talk]]) 09:32, 19 December 2019 (CET) Git was/is a complex package to build - and SO many dependencies. HOWEVER, the good news - no dependencies in this package - EXCEPT for the OpenSSL requirements. NB: git-2.24.1 is a security release fixing something - link comes later - that has been there forever. Now gone!
  

Latest revision as of 12:58, 14 April 2021

Packages|Tools|aixtools.git.2.24.1.0.I
Report Issues (via Forums) and/or TWEET:@aixtools

MD5 Checksum

EC2BAD2C2159C5ABD4A4AA3DC8DB65B5 aixtools.git.2.24.1.0.I

[edit] Package Details

GIT Version: 2.24.1
Release Date: 10-Dec-2019
Sources from: git-2.24.1.tar.xz
Depends on: openssl.base

[edit] Note

--Michael Felt (talk) 13:58, 14 April 2021 (CEST) Going to update this soon.

--Michael Felt (talk) 09:32, 19 December 2019 (CET) Git was/is a complex package to build - and SO many dependencies. HOWEVER, the good news - no dependencies in this package - EXCEPT for the OpenSSL requirements. NB: git-2.24.1 is a security release fixing something - link comes later - that has been there forever. Now gone!

So the requirements: OpenSSL (openssl.base 1.0.2.1000 as minimum, current AIX release is: 1.0.2.1801, oops - since 2019.12.07 it is 1.0.2.2001) CVE-2019-1547 and CVE-2019-1563.

Further, you will need something to prevent this message when cloning using ftp or http (these rely on the curl library)

fatal: unable to access 'https://github.com/aixtools/cpython.git/': error setting certificate verify locations:
CAfile: /var/ssl/cacert.pem

I satisfy this requirement via the curl website (see my curl page for added details if you do not have something similar already).

The other dependencies (that used to be provided as a bundle - are now embedded using static links rather than shared libraries. The list is:

 static.curl.adt           7.67.0.0    C     F    static curl ADT files
 static.expat.adt           2.2.9.0    C     F    static expat ADT files
 static.gnu.gettext.adt    0.20.1.0    C     F    gnu gettext ADT files
 static.gnu.libiconv.adt   1.16.0.0    C     F    gnu libiconv ADT files
 static.libssh2.adt         1.9.0.0    C     F    static libssh2 ADT files

Note: ADT stands for Application DevelopmenT


--Michael Felt (talk) 10:01, 24 September 2019 (CEST) I also have a version at 2.18.0, but ut has different dependencies. If you need git, higher than 2.10.1, just post on the forums and I get something newer posted.

--Michael Felt (talk) 06:06, 19 October 2016 (UTC) All older links were removed. While they will work if you download the latest dependencies I feel it is messy. Better to start with the latest.

And use the bundle if you are new to AIXTOOLS. Just download, uncompress and untar to a directory, then use installp to install from a directory.

[edit] Archive

15B5A4491883C79058B981365C9B514F aixtools.git.2.10.1.0.I
E2E843A6DC107EDD55A9F5012EEABFA5 aixtools.git.2.10.1.bundle.tar.bz2
Personal tools
Namespaces

Variants
Actions
Navigation
Downloads
Toolbox