wget

From AIXTOOLS
Jump to: navigation, search

Packages|GNU|aixtools.gnu.wget.1.19.4.0.I
Report Issues (via Forums) and/or TWEET:@rootvgnet
MD5 Checksums

A88398CA67B9E7D98C42825946895D4A aixtools.gnu.wget.1.19.4.0.I

Contents

Package Details

Version: 1.19.4
Released: 2018-01-21
Source: https://ftp.gnu.org/gnu/wget/wget-1.19.4.tar.gz
Depends on: stand-alone! Hurrah!! - although - still needs openssl.base 1.0.2.100

Instructions for TLS/SSL

wget uses the default settings of the system OpenSSL. On AIX, there is no default for the location of the CA certificates. As such, you may see a message such as:

michael@x071:[/var/wget/etc]wget https://ftp.gnu.org/gnu/make/make-4.2.1.tar.bz2
--2018-04-18 08:44:19--  https://ftp.gnu.org/gnu/make/make-4.2.1.tar.bz2
Resolving ftp.gnu.org... 208.118.235.20
Connecting to ftp.gnu.org|208.118.235.20|:443... connected.
ERROR: cannot verify ftp.gnu.org's certificate, issued by 'CN=Let\'s Encrypt Authority X3,O=Let\'s Encrypt,C=US':
 Unable to locally verify the issuer's authority.
To connect to ftp.gnu.org insecurely, use `--no-check-certificate'.

To correct this, you need to download a PEM based file, and add a line to the file /var/wget/etc/wgetrc pointing to that file, such as:

ca-certificate=/var/ssl/cacert.pem

FYI: I get my file from the curl site. See https://curl.haxx.se/docs/caextract.html

NEWS

--Michael Felt (talk) 20:27, 17 April 2018 (CEST) Likewise, a package that does not require GNU gettext nor libiconv. And, although much much later than expected - I present the latest version of wget!

--Michael Felt (talk) 07:11, 31 July 2015 (UTC) Repackaged with openssl.base dependency lowered to version openssl.base.1.0.1.510. Still recommend that you update openssl.base asap (via IBM WebPacks for AIX rather than wait for a new service pack with a new openssl.base). With the latest OpenSSL packaging from IBM WebPacks for AIX you can even install an ifix available via ftp://aix.software.ibm.com/aix/efixes/security/openssl_advisory14.asc. And, yes, I am being pushy about it.

--Michael Felt (talk) 09:36, 30 July 2015 (UTC) repackaged with OpenSSL 1.0.1 and removed dependency on pcre (where did that come from??)

--Michael Felt (talk) 20:39, 11 June 2015 (UTC) wget-1.16.3 is packaged, but make check is still not 100%

--Michael Felt (talk) 16:53, 2 March 2015 (UTC) removed wget-1.16.0 (with ssl support) because of conflicts with existing libraries.

Archive

E75CD9451CFD33120421AFB814B08C8C aixtools.gnu.wget.1.18.0.0.I
4F0C55D1489EFF5A1A40DC27D91B73FA aixtools.gnu.wget.1.18.bundle.tar.bz2
EB94A79C4D36B01563FB531252809259 aixtools.gnu.wget.1.16.3.0.I
CE85E18A01F5C4FB540DCB2CC5F549E6 aixtools.gnu.wget.1.16.3.bundle.tar.bz2
Personal tools
Namespaces

Variants
Actions
Navigation
Downloads
Toolbox